Results 1 to 8 of 8

Thread: Returning Mac player (...help!)

  1. #1
    Join Date
    Dec 2007
    Location
    Sand Hill Road
    Posts
    124

    Default Returning Mac player (...help!)

    Hi all,

    I'm back in the lands after a few years, and am running into difficulties in getting Lich up and installed with Mac OS X. Like hamsquatch mentioned here:

    http://forum.gsplayers.com/showthrea...9-Lich5-on-Mac

    I am not even able to get "brew doctor" to confirm Homebrew is working.

    Is anyone with Lich successfully running willing to shoot met a quick message? I'm happy to provide plenty of silvers for any assistance

    Thanks!!


    (Sorry... I know... but I really don't want to deal with Bootcamp... )

  2. #2

    Default

    Might need to get over to discord. But before going through all that what type of errors are you seeing when you try to install homebrew?

  3. #3
    Join Date
    Dec 2007
    Location
    Sand Hill Road
    Posts
    124

    Default

    Thanks Risen - Discord will be my next step.

    For now, I found a workaround that seems to work. I'll summarize in case it helps anyone having similar issues:

    My system: MacBook Pro., Mac OS X Ventura (13.0.1), Chip: M1 Max

    Follow the instructions here, which a few modifications:

    https://gswiki.play.net/Lich:Software/Mac_Installation

    NB: Instead of Ready to Brew, the "brew doctor" command will give warnings about updates, which can be ignored.

    Continue following the installation steps, except wherever the instructions say to use rbenv 2.7.7, replace that with 3.2.2 (or whatever your system uses)

    At the end, within irb, expect that the "require 'gtk3'" confirmation will fail (instead of responding 'true', like the instructions say).


    I'm sure this is not the optimal overall approach.. but it got me up and running!

    Thanks all.

  4. #4

    Default

    I had a lot of issues working through my macbook pro to get everything working. I don't know if you use parallels but I'd recommend looking into it and running wrayth and doing the windows install because avalon was straight trash as a front end.
    R.I.P. Bushido Brown

  5. #5

    Default

    You might find your lich windows acting oddly. Great progress!

  6. #6

    Default

    Quote Originally Posted by Risen View Post
    You might find your lich windows acting oddly. Great progress!
    I have 0 problems with lich in parallels other than the installation, I had to install the previous package to 5.7 and then update it 5.7 because the ruby version 3.2.2 doesn't work (at the time.. maybe yet?) but other than that no issues.

    I mean not everyone wants to pay for parallels just to play their 40 year old text game but it's just a quick .02 if they're still having issues.
    Last edited by Sean; 01-03-2024 at 09:59 PM.
    R.I.P. Bushido Brown

  7. #7
    Join Date
    Oct 2004
    Location
    The United Kingdom
    Posts
    16,082

    Default

    I tried to install lich on MacBook a few years ago with the help of Doug from the officials. He spent HOURS literally directing me and helping me. He was miraculous honestly with the level of help he gave me at night.
    After all that it didn’t work and we couldn’t figure it out so I’ve been using a bootcamp partition ever since. It’s horrible.
    I’d give anything to run GS and lich on my macOS so I’m going to use the steps you gave above and see if it works with another shot.
    Thanks for taking the time to show us the extra steps you took, most wouldn’t do that.

    Also Sean, I’ve never heard of parallels. It sounds like running a virtual machine on macOS which i tried before bootcamp. It almost set my MacBook on fire hah
    I’ll go check that out too.

  8. #8

    Default

    Quote Originally Posted by Asha View Post
    I tried to install lich on MacBook a few years ago with the help of Doug from the officials. He spent HOURS literally directing me and helping me. He was miraculous honestly with the level of help he gave me at night.
    After all that it didn’t work and we couldn’t figure it out so I’ve been using a bootcamp partition ever since. It’s horrible.
    I’d give anything to run GS and lich on my macOS so I’m going to use the steps you gave above and see if it works with another shot.
    Thanks for taking the time to show us the extra steps you took, most wouldn’t do that.

    Also Sean, I’ve never heard of parallels. It sounds like running a virtual machine on macOS which i tried before bootcamp. It almost set my MacBook on fire hah
    I’ll go check that out too.
    Ha I don't know which macbook you have I can say Parallels runs like a champ on my M1 and I have no problems running wrayth/lich but like I said I wouldn't install 5.7 right off the rip I had to do a previous version and upgrade because ruby 3.2.2 + lich didn't work. Not sure if that's been fixed with 5.8
    R.I.P. Bushido Brown

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •