Results 1 to 2 of 2

Thread: Lich won't connect with Stormfront.

  1. Default Lich won't connect with Stormfront.

    I have been trying all day to figure out how to get Lich to work. And I've tried to find an answer to my problem on the forum, couldn't find it so I'm making a thread. I can get lich to work and I can put my login in game entry and even find my character. But once I hit play start Lich closes and nothing happens. I go to stormfront and no lich commands work and it never showed anything suggesting they've connected, it seems like it should have opened SF and began downloading things for it's first run, but it just isn't starting SF, or Wizard. It also can't link to either the website launch chain or SGE, which I downloaded. Am I doing something wrong? Also this is for Dragon Realms, I recently paid for a sub and decided to try to get lich to work for it. I've tried multiple versions of lich including one that's supposed to be for Dragon Realms and I've tried the RUBY4Lich and the old 2.0 version of Ruby. Any help would be greatly appreciated, thanks.

    Edit: Debug file: 2020-10-28 15:48:23: info: Lich 4.6.52
    2020-10-28 15:48:23: info: Ruby 2.5.5
    2020-10-28 15:48:23: info: i386-mingw32
    2020-10-28 15:48:24: info: no force-mode info given
    2020-10-28 15:48:50: error: failed to find the Simutronics launcher
    Last edited by Xilescient; 10-28-2020 at 06:56 PM.

  2. Default

    Quote Originally Posted by Risen View Post
    There's the issue. I'm not clear where you are in the process. Did you do a restore after the installer, or before and then run the installer again?

    The fix itself isn't too hard if the installer was the last activity done. On Windows 8 or 10, open up Windows Explorer (File Explorer) and click on MY PC, then double click C DRIVE. Double click the Ruby directory, then double click the Bin directory. Click one time on RUBYW to select that file, then RIGHT CLICK on that file and select PROPERTIES.

    Then click on the COMPATIBILITY tab, check the box to 'Run the program in compatibility mode for', and then select WINDOWS 7 in the drop down list.

    APPLY / OK, close your Windows Explorer, and try to log into the game.
    This worked!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts