Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Lich v3.57 + Vista

  1. #1

    Default Lich v3.57 + Vista

    Had anyone made this work?

    I can only get v3.5 to work.

    HALP PLZ!
    No matter how big and powerful government gets, and the many services it provides, it can never take the place of volunteers.

  2. Default

    I was able to, though it took a lot of poking stuff to get it to play nice with Psinet (which conveniently has been down for a while). I don't recall exactly what I did, though I remember having to do clean installs of Lich, Psinet and the game launcher, so I lost all my downloaded scripts, aliases and goto locations. I also installed Lich to the registry.

    Now, it doesn't work perfectly. When I log in, I get the line: [lichnet: The script has encountered a minor error! Your character name was not autodetected properly; checking it now...]

    It seems to work fine after that, though. I do remember having to force my character names a few times when I logged them in the first time around by quitting lichnet and using ;lichnet char.init(Character name).

    Gretchen

  3. #3
    Join Date
    Apr 2005
    Location
    Close enough to Pittsburgh
    Posts
    1,723

    Default

    I just got vista and 3.57 to work. I had to remove anything previous... I had SF instal via Active X. Then I installed the SGE, and then Lich. I have to log with Force SF mode. Trying to log with SGE was wonky at best.

    Gibreficul

  4. #4

    Default

    I've never got the new SGE to work with Lich, no matter the OS. I use the older version of SGE.

  5. #5
    Join Date
    Feb 2004
    Location
    Queens, New York
    Posts
    799

    Default

    I use Brian's AutoSGE. Psinet and Lich work fine.

  6. Default

    Thanks to vista consant breaking i have been through several installs so thought i may as well post how i got it working(all these steps may or may not be needed, but it has worked everytime for me).

    First i installed SF, the game launcher and the SGE from the website(if you havent turned those damn UAC's warnings off yet you should do so before installing that) and then i logged in via the SGE to make sure that worked.

    NExt i installed lich. I right clicked on the "install to registry" options and ran it as administrator. I did this twice just for the hell of it, ignoring what ever erros it gave me. I then checked i could still log in to the game, which i could but lich was not working. I then used the "force StromFront mode" and it loaded up the SGE for me and i logged in fine with lich. Even though i couldnt run lich with out the forcing SF mode i carried on anyway.

    Finally i just installed psinet as normal. Logged in via the SGE and all was good.

    When i log in it does not pick up my charchter name automatically but it seems to send the "info" comand and gets the name from that. The only thing of annoyance is i have to manually ";reload" my settings for scripts relying on them to work.

  7. #7

    Default

    hey all. finally making my return to gsiv but i need to get lich for linux. anyone know the site where i can get it?

  8. #8

  9. #9

    Default

    Quote Originally Posted by stormtov View Post
    Thanks to vista consant breaking i have been through several installs so thought i may as well post how i got it working(all these steps may or may not be needed, but it has worked everytime for me).

    First i installed SF, the game launcher and the SGE from the website(if you havent turned those damn UAC's warnings off yet you should do so before installing that) and then i logged in via the SGE to make sure that worked.

    NExt i installed lich. I right clicked on the "install to registry" options and ran it as administrator. I did this twice just for the hell of it, ignoring what ever erros it gave me. I then checked i could still log in to the game, which i could but lich was not working. I then used the "force StromFront mode" and it loaded up the SGE for me and i logged in fine with lich. Even though i couldnt run lich with out the forcing SF mode i carried on anyway.

    Finally i just installed psinet as normal. Logged in via the SGE and all was good.

    When i log in it does not pick up my charchter name automatically but it seems to send the "info" comand and gets the name from that. The only thing of annoyance is i have to manually ";reload" my settings for scripts relying on them to work.
    Thanks Stormtov!!!!

    This plus a registry cleaner to clear all my previous installs worked.

  10. #10

    Default

    I can't get past the permission denied to install to registry.
    Any help?
    Vista install of lich is what I want to get running

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •