Results 1 to 7 of 7

Thread: GTK Issues

  1. #1
    Join Date
    May 2010
    Location
    With your mom
    Posts
    5,699

    Default GTK Issues

    So I downloaded Lich5. Looks like a new version of GTK is downloaded that screws up previous scripts?

    Getting errors like this when I try to run a script like ;sbounty

    >;sbounty setup
    --- Lich: sbounty active.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    'Gtk::ComboBox#append_text' is deprecated; use 'Gtk::ComboBoxText#append_text' instead
    --- Lich: sbounty has exited.
    How do I fix this?

  2. #2

    Default

    download updated version of ;sbounty?

  3. #3
    Join Date
    May 2010
    Location
    With your mom
    Posts
    5,699

    Default

    >;repo info sbounty.lic
    --- Lich: repository active.

    file size last update author DLs rating
    ----------- ----- ------------------ -------- ---- --------
    sbounty.lic 67.7k 2019-01-05 9:38pm spiffyjr 1747 10.0 (1)

    available versions: 1.0


    SBounty by SpiffyJr (spiffyjr@gmail.com)

    Does all bounties except gem, escorts, and bandits. Gems should
    be handled via your loot with stockpiling.

    Feel free to send donations or Gift's of Adventure.

    author: spiffyjr
    email: theman@spiffyjr.me
    name: SpiffyBounty
    tags: bounty
    version: 1.0
    I don't think its been updated.

    I upgraded lich because I'm having issues with the ;cure script. Here is what I get when I run it:

    >;cure
    --- Lich: cure active.
    --- Lich: error: can't convert NilClass to String (NilClass#to_str gives NilClass)
    C:/Users/XXX/lich/lich.rbw:8032:in `escape'
    C:/Users/XXX/lich/lich.rbw:8032:in `[]'
    --- Lich: cure has exited.
    So I thought I'd upgrade since it looks like a lich error. After upgrading to Lich5 though ;cure setup is jacked up because of GTK3. I have no idea why I'm getting this error in the first place.

    I reverted everything back to my previous installation and still getting the error.
    Last edited by Fortybox; 07-05-2021 at 11:23 AM.

  4. #4

    Default

    You can update your scripts here or via jinx.
    https://github.com/elanthia-online/g...master/scripts

    Also make sure these aren't set to autoupdate in lich. More help available on discord.
    Last edited by Rinualdo; 07-05-2021 at 01:10 PM.
    I don't want the world; I just want your half.
    Discord BigNasty#8519

  5. #5
    Join Date
    May 2010
    Location
    With your mom
    Posts
    5,699

    Default

    I think I got it fixed but I don't know why or how.

  6. #6

    Default

    Watch out for Elanthia Online though, I heard it's run by HoA and those guys are taking over everything.
    Find me in game as Alastir
    Or on Discord as: Alastir#9661

  7. #7
    Join Date
    May 2010
    Location
    With your mom
    Posts
    5,699

    Default

    Quote Originally Posted by Alastir View Post
    Watch out for Elanthia Online though, I heard it's run by HoA and those guys are taking over everything.
    That kind of sarcasm would only work if you weren't such a power hungry stalker.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •