Page 7 of 7 FirstFirst ... 567
Results 61 to 69 of 69

Thread: problems installing lich

  1. #61

    Default

    Well, I'm another newbie needing help. Tonight I logged on as normal, and all of a sudden I couldn't connect to ;lnet nor could I run bigshot because I don't have a map database anymore?

    I uninstalled everything multiple times. I have installed ruby4lich, and installed lich 4.6.52 about a half dozen times. When I log back into gemstone I get a repository error when it first loads up. I can't run any movement apps like ;narost or ;go2 because I have no map database, and I can't use ;lnet. It says it'll try restarting after 299 seconds.

    Any ideas?

    This is what is says when I log in:
    --- Lich: alias service started
    --- Lich: lnet active.
    --- Lich: repository active.
    [repository: error: unrecognized command. Try ;repository help]
    --- Lich: repository has exited.
    [lnet: connection lost]
    [lnet: waiting 299 seconds before trying to reconnect...]

    and when I try to use ;go2:
    >;go2 bank
    --- Lich: go2 active.
    --- Lich: error: no map database found
    [go2: error: your current room was not found in the map database]
    --- Lich: go2 has exited.

    I solved the map database issue by ;repo download-mapdb about an hour after I posted this. I still can't figure out the lnet problem. Please help, and thank you.
    Last edited by Donaven; 06-18-2020 at 02:21 AM.

  2. Default

    lich error.jpg

    Finally got all the ruby stuff sorted out, and now I'm getting this error. I've moved Lich, deleted and reinstalled lich, done a search for lich.exe...I'm at a bit of a loss. Running windows 10 64 bit home edition if that makes a difference.

  3. Default

    *solved*
    Last edited by MadHatter; 07-22-2020 at 11:37 PM.

  4. #64

    Default

    Anyone have the contents of their gem.bat and gem.cmd files that they'd post here? I keep getting an error that gem.cmd or gem.bat cannot be found in my directory. Gem.cmd is definitely there but I'm still stuck at it trying to install sqlite3. Maybe manually making the file it wants will help move me along.
    Last edited by heguo; 07-29-2020 at 03:13 PM.

  5. #65

    Default

    For any who may be curious, I managed to solve the problem. I had to manually download Ruby 2.6.6-1 (x86) and then install sqlite 3 and gtk2. Once I did that, I rebooted, set the rubyw file in the Ruby26 folder to run in Win 7 compatibility mode, and it worked.

  6. #66

    Default

    I'm trying to install lich on a new computer, and have followed the advice in here, but continue to have the following issue with the sqlite3 install

    C:\>c:\ruby200\bin\gem.bat install sqlite3 --source http://rubygems.org --no-ri --no-rdoc
    Fetching: sqlite3-1.4.2.gem (100%)
    ERROR: Error installing sqlite3:
    The 'sqlite3' native gem requires installed build tools.

    Please update your PATH to include build tools or download the DevKit
    from 'http://rubyinstaller.org/downloads' and follow the instructions
    at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'

    When I try just running Lich and tell it to install the command prompt never opens, it just kills the load completely. So nothing seems to be working, I tried clearing out any remnants of Ruby and reinstalling but hit the same issue every time. Any help is appreciated.

    Thanks,
    (farmervivaldi) You can't handle the Roh

  7. Default

    Quote Originally Posted by LordAlarinn View Post
    Ok, after fiddling with the launcher and manually pointing Lich to the location where the SIMU launcher exists, I got it to work. This is what I see in the Stormfront content area:

    --- Lich: infomon active.
    --- Lich: alias service started
    --- Lich: lnet active.
    --- Lich: repository active.
    [repository: error: unrecognized command. Try ;repository help]
    --- Lich: repository has exited.

    --- Welcome to LNet. I think so, Brain! But no more eels in jelly for me, thanks--I like my gelatin after lunch.

    Not sure what command it had issues with, but I can type in ;repository help in Stormfront. At least I have a better way of getting into the game. Now I just need to figure out a way to do this for 2 accounts. Also I tried for kicks the ;go2 script and got a no map database found so I downloaded it using ;repository download-mapdb and tried again but get a 'your current room was not found in the map database'. So I moved around a bit since I think I was close to the Silverwood Manor and stood outside the Furrier shop and ;go2 bank took me to the bank. So good to go and thanks for your help. Now to go find the scripts forum to look for a ranged combat script (cause right now ranged combat sucks on my halfling rogue).
    Hi I think I have the same problem but I can't figure out how to point Lich to where the SIMU launcher exists, can someone help me with that?
    2020-10-28 15:48:23: info: Lich 4.6.52
    2020-10-28 15:48:23: info: Ruby 2.5.5
    2020-10-28 15:48:23: info: i386-mingw32
    2020-10-28 15:48:24: info: no force-mode info given
    2020-10-28 15:48:50: error: failed to find the Simutronics launcher

    Edit: This worked!
    Quote Originally Posted by Risen View Post
    There's the issue. I'm not clear where you are in the process. Did you do a restore after the installer, or before and then run the installer again?

    The fix itself isn't too hard if the installer was the last activity done. On Windows 8 or 10, open up Windows Explorer (File Explorer) and click on MY PC, then double click C DRIVE. Double click the Ruby directory, then double click the Bin directory. Click one time on RUBYW to select that file, then RIGHT CLICK on that file and select PROPERTIES.

    Then click on the COMPATIBILITY tab, check the box to 'Run the program in compatibility mode for', and then select WINDOWS 7 in the drop down list.

    APPLY / OK, close your Windows Explorer, and try to log into the game.
    Last edited by Xilescient; 10-28-2020 at 08:09 PM.

  8. #68

    Default

    on 18.04 and cant get lich installed to save my life
    [LNet]-You: "lnets for everything, fuck a mod"

    [LNet]-GSIVreaer: "Empath is a bad mother fucker"

    -Original Shattered Snoopy/Empath/Psycho

  9. #69

    Default

    Try deleting all your old Lich files then use the link from the wiki to reinstall

    https://gswiki.play.net/Lich_(software)

  10. #70

    Default

    Hi all. I also am having a problem installing Lich on a brand new laptop. My old laptop installed it and ran exactly as advertised. I follow the instructions from wiki and the Lich site but each time I double click the Lich.rbw icon a window pops up asking "How do you want to open this .rbw file?" Beneath it says Keep using this app, and under that is "D:\Ruby25\bin\rubyw.exe" "%1" %". I click Ok and the window just appears again. Even the icon of the Lich.rbw look different than from my old PC. Tried many time installing this, from wiki and selecting ruby installer and downloading lich from the lich site. I can use a computer but don't know anything about software. Hope someone can give me a hint or been through this too and has a fix. I searched and found no other old ruby or lich files on the drive I load things on btw. Thanks.

    Looked at ALL the files in my old laptop Ruby folder and compared them to what was downloaded in my new laptop and there were a bunch of files missing. I don't know why, erased lich from my old pc and reinstalled it and it was fine, did that to my new pc and same thing - missing files(?????). Mainly it was in the RubyLich>lib>ruby>gems>2.5.0 cache, specifications, and gems folder. So I copied all the missing files to a thumb drive and pasted it where they needed to go in the RubyLich folder and it works. Also, I dont know why, but I had to link the Lich.rbw to the RubyLich>bin>rubyw application (the white one) and then the shortcut appeared like how it is on my old pc. My forte is airplanes so this was a strain for me. Hope this helps someone else.
    Last edited by Nikai; 12-21-2020 at 08:42 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •