Page 6 of 6 FirstFirst ... 456
Results 51 to 59 of 59

Thread: problems installing lich

  1. #51

    Default

    When you get back to the point where you have Ruby4Lich installed, but you don't see a lich folder, at that point the easist fix is:

    Go to lichproject.org/download.html
    Scroll down to the link for Lich-4.6.52.zip
    Download that
    Unzip it, and move the unzipped Lich folder to your desktop
    Open the Lich folder on your desktop and double-click lich.rbw file

    From there, it should all work

  2. Default

    Quote Originally Posted by LordAlarinn View Post
    I'm having issues as well. Installed Ruby4Lich for the very 1st time and never had any version of Ruby. I unchecked all of the Simu installs since I have Stormfront installed already. But once things are finished, I go into my Ruby4Lich folder and there is no lich.rbw file. The only files I see are LICENSE.txt, and 4 unins files and everything else is a folder. I checked as many folders as I could but nothing. If I go to Add Remove programs, I see Ruby 2.5.5-1x86 and Ruby4Lich version Ruby 2.5.5-x86. I uninstalled Lich already per the comments here and reinstalling didn't change anything.
    One other note, the launcher never works for me. Even though I have the launcher installed, the only way to get Stormfront to come up is to take the stupid sal file the launcher always downloads and right click on it and select run with -> Launcher.
    Last edited by LordAlarinn; 04-14-2020 at 10:56 AM.

  3. Default

    Ok did that but when I double click the lich.rbw file and select yes to install gtk2, it fails when it tries to run gem.bat, but the only gem file I see in the /bin folder is gem.cmd.

  4. #54

    Default

    Leave the lich folder where it is.

    Uninstall Ruby4Lich from the control panel / apps
    Delete the directory Ruby4Lich if it remains
    Reboot
    Reinstall Ruby4Lich - only Ruby / Gems, uncheck everything else
    Install to the C drive, not to a network drive or other local disk
    There will be DOS windows that open, they will automatically close
    Let it run, when all is complete it will automatically close
    Do not close any of the windows, even if they look stuck, let them run
    Last edited by Risen; 04-14-2020 at 11:17 AM.

  5. Default

    Quote Originally Posted by Risen View Post
    Leave the lich folder where it is.

    Uninstall Ruby4Lich from the control panel / apps
    Delete the directory Ruby4Lich if it remains
    Reboot
    Reinstall Ruby4Lich - only Ruby / Gems, uncheck everything else
    Install to the C drive, not to a network drive or other local disk
    There will be DOS windows that open, they will automatically close
    Let it run, when all is complete it will automatically close
    Do not close any of the windows, even if they look stuck, let them run
    Ok, I'll give that a try. I did install to one of my other 8 drives (yeah I'm a geek) because I hate to fill up the crucial boot drive with crap (why I rerouted Downloads and Documents away from the C: drive). But it'll be a small folder any way.

  6. Default

    Ok, after fiddling with the launcher and manually pointing Lich to the location where the SIMU launcher exists, I got it to work. This is what I see in the Stormfront content area:

    --- Lich: infomon active.
    --- Lich: alias service started
    --- Lich: lnet active.
    --- Lich: repository active.
    [repository: error: unrecognized command. Try ;repository help]
    --- Lich: repository has exited.

    --- Welcome to LNet. I think so, Brain! But no more eels in jelly for me, thanks--I like my gelatin after lunch.

    Not sure what command it had issues with, but I can type in ;repository help in Stormfront. At least I have a better way of getting into the game. Now I just need to figure out a way to do this for 2 accounts. Also I tried for kicks the ;go2 script and got a no map database found so I downloaded it using ;repository download-mapdb and tried again but get a 'your current room was not found in the map database'. So I moved around a bit since I think I was close to the Silverwood Manor and stood outside the Furrier shop and ;go2 bank took me to the bank. So good to go and thanks for your help. Now to go find the scripts forum to look for a ranged combat script (cause right now ranged combat sucks on my halfling rogue).

  7. #57

    Default

    Just run the lich.rbw file again for a second character instance.

  8. #58
    Join Date
    Apr 2008
    Location
    Isla de Roatan
    Posts
    532

    Default

    Any ideas on why I keep getting this error message?
    Error (2).png
    Cannot install SIMUs launcher from their own download link. It all started when I could no longer login via SIMU SGE. Figured I'd just remove everything and start over with the wiki Lich package. The game launcher installer will not even allow me to change the path for the program. Strange issue.
    Semper superne nitens.

  9. #59
    Join Date
    Apr 2008
    Location
    Isla de Roatan
    Posts
    532

    Default

    Quote Originally Posted by Seizer View Post
    Any ideas on why I keep getting this error message?
    Error (2).png
    Cannot install SIMUs launcher from their own download link. It all started when I could no longer login via SIMU SGE. Figured I'd just remove everything and start over with the wiki Lich package. The game launcher installer will not even allow me to change the path for the program. Strange issue.
    Nevermind I figured it out, a buried registry key.
    Semper superne nitens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •