Page 145 of 145 FirstFirst ... 4595135143144145
Results 1,441 to 1,445 of 1445

Thread: Bigshot: The New Optimus Prime

  1. Default

    If you hunt undead and/or a mix of undead and living targets you can set up two different bundles.

    So in the hunt command lines put:

    ready ammo, fire (set to blessed bundle)
    ready ammo2, fire (non-blessed bundle)

    Also if you are in Voln bigshot won't bless the ammo correctly. Scroll up and use the loop script I posted.

  2. #1442

    Default

    Thought that would have fixed it but no bueno. Here's what I am getting with ammo/quiver both deleted from the tabs and "ready ammo, fire" set for the command line:

    [bigshot]>ready ammo
    You remove a single faewood bolt from a bundle of faewood bolts.
    >
    [bigshot]>aim head
    You're now aiming at the head of your target when using a ranged weapon, or while ambushing.
    >
    [bigshot]>get 1
    >
    Get what?

    I get the same "Get what?" error without the ready ammo as well.
    A gremlock whispers, "You died so easily. You need to get used to it.".

  3. Default

    Quote Originally Posted by nichelas View Post
    Thought that would have fixed it but no bueno. Here's what I am getting with ammo/quiver both deleted from the tabs and "ready ammo, fire" set for the command line:

    [bigshot]>ready ammo
    You remove a single faewood bolt from a bundle of faewood bolts.
    >
    [bigshot]>aim head
    You're now aiming at the head of your target when using a ranged weapon, or while ambushing.
    >
    [bigshot]>get 1
    >
    Get what?

    I get the same "Get what?" error without the ready ammo as well.
    Odd. Do you have the bundle set under ready ammo? Remove all the settings from the Ammo/wand tab as well. That might be causing trouble if you have those settings filled out.

    This is what I get with hunting command: ready ammo, fire

    Code:
    [bigshot]>target #36762513
    You are now targeting a fenghai.
    >
    [bigshot]>ready ammo
    You remove a single wooden bolt from a bundle of wooden bolts.
    >
    [bigshot]>fire #36762513
    You fire a wooden bolt at a fenghai!
      AS: +246 vs DS: +172 with AvD: +35 + d100 roll: +58 = +167
       ... and hit for 47 points of damage!
       Incredible shot to the eye penetrates deep into skull!
    The fenghai falls to the ground motionless.
    The fenghai no longer bristles with energy.
    The glowing specks of energy surrounding a fenghai suddenly shoot off in all directions, then quickly fade away.
    The brilliant luminescence fades from around a fenghai.
    A fenghai appears somehow different.
    The bright luminescence fades from around a fenghai.
    The silvery luminescence fades from around a fenghai.
    The bolt sticks in a fenghai's right eye!
    Roundtime: 5 sec.
    If you are a ranger I'd suggest doing something like this in the hunting command:

    608(m10), cock cross, hide,ready ammo, fire

    You can cock crossbows in soft/casting RT. So its slightly faster to fire.
    Last edited by wetsand; 12-12-2020 at 12:10 AM.

  4. Default Bless and Consecrate 'issue'

    Hi, very new here and to lich scripts. I am using a paly with a permanently sanctified weapon and fighting Ghostly Warriors. I have the 'Bless Weapon' box checked. When my handaxe returns to normal, it casts the consecrate spell fine. The issue arises when I take my next swing: if I hit, everything is great, but if the target dodges, parries, blocks or otherwise does not get hit and take damage, I get sent to the 'no blessed weapon' kill switch and go to my rest spot and bigshot exits.

    For my local file, I have added a global $bigshot_is_consecrate = false variable that I set true in the if/else block that casts 1604 and set false in all the other blocks in that group. In the final else, I only set it to weapon not blessed and must rest if is_consecrate is false, which fixed the problem for my pally and I don't have other characters, especially a cleric, to test that on.

    Also, before I'd trained away all the spell hinderance, spell failure would cause it to hit the 'no bless' kill switch too, instead of casting again.

    Worth mentioning also is that it worked beautifully to refresh consecrate on my sanctified armor and shield when the spell expired.
    Last edited by ChupacabraJones; 12-25-2020 at 08:02 PM.

  5. #1445

    Default

    So bigshot has always worked great foe me, but for some reason now I am getting an error message and bigshot is turning itself off. The message is:

    --- Lich: error: undefined local variable or method `spell' for #<Bigshot:0x0000000014503098>
    bigshot:1213:in `mstrike_spell_check'
    bigshot:1225:in `cmd_mstrike'
    --- Lich: bigshot has exited.

    Anyone have any idea what might be causing it? Is it a setup thing since it is the first time I have used it on this alt. Oh, and he does not train in mstrike, he is a UAC empath, for the time being anyway.

    Edit:

    Just realized one of his enhancives does give him 2 ranks of MOC.
    Last edited by kutter; 01-10-2021 at 04:54 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •