Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Problem installing Lich.

  1. #1

    Default Problem installing Lich.

    Hi, I am pretty new to linux and lich, but I followed all the instructions that were posted. I installed everything.. and when I run ./lich.rb... the install window pops up but its blank, there is no text or buttons or anything. I tried rebooting and everything.. anyone have any ideas?



  2. Default

    A couple people on Linux have had that problem. I'd suggest compiling ruby-gtk2 from source. It's pretty simple. After uninstall the ruby-gnome2 or ruby-gtk2 you currently have installed, just extract the source, change directory, and type:

    ruby extconf.rb
    sudo make install

    You can get the source from

    You may have to install some devel packages in order to compile, depending on your distro. Just look for dev or devel stuck on the end of ruby and gtk packages in your package manager.

    However, the GUI stuff is optional. Assuming you've got the SGE and the Simu launcher installed with WINE, you can type "./lich.rb --install", and log in with the SGE. You just won't be able to use narost (the map viewer). Most scripts with a GUI setup also have a text based setup.
    Get Lich - Vote for Gemstone (

  3. #3


    After I installed Lich my comp got a worm when I tried to run it.. Might want to check the program or something.. (I used the link in the website folder, and downloaded the stable version)

  4. #4


    tried reinstalling ruby... no luck... any other suggestions?


  5. #5


    Freakin Ubuntu.

    I just did the same thing and no dice. Same exact problem.

    Order of operations:
    install Ruby 1.9.1
    install Ruby-gnome2 (this installed Ruby 1.8 for whatever reason)
    Run lich - nothing in the window
    uninstall 1.9.1
    uninstall gnome2
    install gnome2
    Run lich - nothing in the window

    damn gtk bindings.

    Any ideas?

  6. #6


    Are you installing Ubuntu because your Windows 7 Beta license is running out in 2 days too? LOL

  7. #7


    hahaha.. negative.. i installed it because i tried to do a system recovery on my hp laptop and it failed.. and they didnt provide me with recovery cds and they wanted me to order them. f that. :P


  8. #8


    Well I can get it running with
    ruby lich.rb --install

    I did the updates, but 2 things...
    A) Narost doesn't work (obviously, since its the GTK that's the problem in the first place)
    B) I'm getting that whole...
    Cl what?
    thing that I can't remember how to fix.

  9. #9


    I think that's what happens when you choose wizard in the SGE. Always choose stormfront, even if you want wizard. If you want wizard you need the fakestormfront.txt thing.
    "You burn with hunger for food that does not exist."

    Playershops 3

    ~ Azanoth

  10. Default

    You should only have to choose Stormfront in the SGE if you're using PsiNet, because PsiNet will connect to the wrong server if you choose the Wizard. On Linux.. I've never heard of this happening. Check your debug file to see what it's connecting to.
    Last edited by Tillmen; 02-27-2010 at 02:58 PM.
    Get Lich - Vote for Gemstone (

Similar Threads

  1. Installing Lich
    By Mitchem in forum The Lich Project
    Replies: 19
    Last Post: 05-05-2019, 11:19 AM
  2. Need help installing Lich
    By BHawk in forum The Lich Project
    Replies: 0
    Last Post: 02-04-2018, 11:44 AM
  3. Error installing lich
    By SHAFT in forum The Lich Project
    Replies: 3
    Last Post: 04-02-2017, 12:58 AM
  4. Installing Lich
    By shadow34 in forum The Lich Project
    Replies: 2
    Last Post: 01-22-2017, 05:50 PM
  5. Installing Lich
    By trall541 in forum The Lich Project
    Replies: 7
    Last Post: 06-28-2010, 12:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts