Results 1 to 3 of 3

Thread: Can't get sloot to work

  1. #1

    Default Can't get sloot to work

    I was hoping that I could get some help fixing sloot. For some reason when I try to run setup it gives me a bunch of error messages (see below) and wonít remember the options I set. Someone mentioned it could be the version of Ruby Iím running. I re-downloaded everything from gemstone wiki about a month ago. Iím awful with computers and scripting so any help is mucho appreciated. Thx.

    PS: Bigshot seems to work ok.

    ;version
    --- Lich: version active.
    ```
    Ruby version........: 2.6.6
    Ruby platform.......: i386-mingw32
    Ruby engine.........: ruby
    Lich version........: 5.0.4
    SQLite3 version.....: 1.4.2
    Gtk version.........: 3.24.24
    Cairo version.......: 1.17.4
    ;version Version....: 0.53

    LICH_DIR............: C:/Users/Robert/Desktop/Lich5
    SCRIPT_DIR..........: C:/Users/Robert/Desktop/Lich5/scripts
    DATA_DIR............: C:/Users/Robert/Desktop/Lich5/data
    TEMP_DIR............: C:/Users/Robert/Desktop/Lich5/temp
    LOG_DIR.............: C:/Users/Robert/Desktop/Lich5/logs
    MAP_DIR.............: C:/Users/Robert/Desktop/Lich5/maps
    BACKUP_DIR..........: C:/Users/Robert/Desktop/Lich5/backup
    Ruby location.......: C:/Ruby4Lich5/bin/rubyw.exe

    MapDB filename................: map-1617628927.json
    MapDB last modified...........: 2021-04-05 09:26:46 -0400
    gameobj-data last modified....: 2021-04-03 17:37:05 -0400
    spell-list last modified......: 2021-02-06 14:25:40 -0500

    Running scripts.....: infomon, lnet, version
    Downstream hooks....: fix_gameobj_status, lnet-watch-forage
    Upstream hooks......: infomon, alias-service, lnet
    Current threads.....: 15
    ```
    Use `;version SCRIPT [SCRIPT2 [SCRIPT3...]]` to report the installed versions of one or more Lich scripts.
    Use `;version ALL` to report the installed versions of ALL downloaded Lich scripts.
    --- Lich: version has exited.

    >;repo info sloot.lic
    --- Lich: repository active.
    file size last update author DLs rating
    --------- ----- ------------------ -------- ---- --------
    sloot.lic 77.1k 2020-03-19 11:22am spiffyjr 4725 10.0 (3)
    available versions: 3.0, 3.2, 3.3, 3.4, 3.5
    SpiffyLoot by SpiffyJr
    todo: add auto-looting
    author: SpiffyJr
    name: SpiffyLoot
    tags: loot
    version: 3.5
    changelog:
    3.5 (2020-03-19)
    Removing Gtk::Tooltips to prep for Gtk3
    3.4 (2019-01-15)
    Attempting fix for finding sacks for item TYPE in any order
    3.3 (2017-12-18)
    Attempting to fix phasing for sorcerors.
    Reorder changelog, new shit on top, duh.
    3.2 (2016-06-19)
    Updated the get_item and put_item code to not care about your container
    3.1 (2016-01-27)
    Added ability to try and sell boxes at pawn (useful for after a lockpick session if you keep mithril ones)
    Added ability to sell scarabs at the gemshop
    3.0 (2015-11-19)
    Add massive boulder skinning as a rolled up krynch sushi roll
    --- Lich: repository has exited.

    Error messages:

    >;sloot setup
    --- Lich: sloot active.
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::Entry#set_text' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::ToggleButton#set_active' no longer accepts nil values; fix me
    'Gtk::Notebook:set_tab_border()' is deprecated; fix me
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    [sloot: closed without saving]
    --- Lich: sloot has exited.

  2. #2

    Default

    Try ;repo download gtk3-sloot, then go to your script directory and rename the file to sloot. See if that works.
    Last edited by Rinualdo; 04-08-2021 at 08:56 AM.
    I don't want the world; I just want your half.
    Discord BigNasty#8519

  3. #3

    Default

    Quote Originally Posted by Rinualdo View Post
    Try ;repo download gtk3-sloot, then go to your script directory and rename the file to sloot. See if that works.
    Yes that worked! Thank you much!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •