Results 1 to 3 of 3

Thread: Recent install, problems with script GUI giving screenscroll about gtk and not saving

  1. Default Recent install, problems with script GUI giving screenscroll about gtk and not saving

    So, yesterday I decided to redownload and after some problems initially I installed from the wiki link and everything is fine EXCEPT that for scripts with GUI setups it gives me a shit ton of screen scroll and doesn't save variables on exiting. For example, when I run ;betazzherb setup I get this:

    >;betazzherb setup
    --- Lich: betazzherb active.
    'Gtk::Tooltips#enable' is deprecated; use 'Gtk::Tooltip' API instead
    'Gtk::Tooltips#set_tip' is deprecated; use 'Gtk::Tooltip' API instead
    'Gtk::Tooltips#set_tip' is deprecated; use 'Gtk::Tooltip' API instead
    'Gtk::Tooltips#set_tip' is deprecated; use 'Gtk::Tooltip' API instead
    'Gtk::Tooltips#set_tip' is deprecated; use 'Gtk::Tooltip' API instead
    'Gtk::Tooltips#set_tip' is deprecated; use 'Gtk::Tooltip' API instead
    'Gtk::Notebook:set_tab_border()' is deprecated; fix me
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::Hbox' is deprecated; use 'Gtk::Box.new(:horizontal, spacing)'.
    'Gtk::VBox' is deprecated; use 'Gtk::Box.new(:vertical, spacing)' instead
    [betazzherb: settings saved]
    --- Lich: betazzherb has exited.

    Note that I did save my settings, but upon reopening everything is blank once again. Is there a way to fix this?

    Thank you!

  2. #2

    Default

    It looks like you installed the beta installer which has a new program in it for displaying graphics and interfaces. The script you are running came from the repository and is not the converted script, so it does not work right.

    I think you need to swing by the Simu Discord scripting channel and get help there. Another option is to uninstall what you installed, and install the current Ruby 2.5 installer. http://bit.ly/WinLich . Do not install the Simu files again.

  3. Default

    Downloading from that link fixed it. Not sure how I got the wrong thing exactly, probably was high. Thank you very much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •