Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Bigshot Lag

  1. Default Bigshot Lag

    Anyone know why Bigshot has increasingly been lagging stormfront after running for a few minutes? Ending the script immediately causes the lag to stop, but it can get so bad that it literally freezes the game until you do so. Then it will catch up with screen scroll for days. Restarting the script seems to work normally for a bit, but the lag returns after a few minutes. Seems to be worst in crowded areas like TSC. I'm running the latest versions of Ruby and Lich, so can't figure out why this is happening more and more now.

    Anyone else have this experience? Fixes?

  2. #2
    Join Date
    Feb 2010
    Location
    Louisville, KY
    Posts
    1,059

    Default

    Are you running the 64 bit version of Lich? I had similar issues and switched to the i386 version and all my latency and slowness issues vanished.


    Selling Stuff and Things
    Adakos#0001 on Discord or Elgrim on the Official GS Discord server under Nitro Boosters.

  3. Default

    I'm running Lich 4.6.54 and yes I think its the 64 bit thatcomes with the ruby installer. How do i get/find the i386 version? Not showing up on any of the lich project pages.

  4. #4
    Join Date
    Feb 2010
    Location
    Louisville, KY
    Posts
    1,059

    Default

    Use the installer at https://gswiki.play.net/Lich_(software)

    Make sure you are selecting the non-64 bit option if it presents itself. Make sure you are only installing Ruby when you run the installer, don't check the boxes to install Lich itself or it will overwrite your existing install. I'd recommend renaming your current folder where Ruby is installed on your PC and also backing up your Lich install folder just in case.

    I was blown away by how much faster it runs once I did this.


    Selling Stuff and Things
    Adakos#0001 on Discord or Elgrim on the Official GS Discord server under Nitro Boosters.

  5. Default

    That's what i did last week to try and fix the problem and it didn't make a difference. Just tried again and there is no option to install a non-64 version of lich that I can see...

  6. #6

    Default

    There is a script on the repo called version.lic.

    Download that script and run it. Copy the results up here for review.

  7. Default

    >;version
    --- Lich: version active.
    ```
    Ruby version........: 2.5.5
    Ruby platform.......: i386-mingw32
    Ruby engine.........: ruby
    Lich version........: 4.6.54
    SQLite3 version.....: 1.4.0
    Gtk version.........: 2.24.30
    Cairo version.......: 1.16.0
    ;version Version....: 0.5

    LICH_DIR............: C:/Ruby4Lich/lich
    SCRIPT_DIR..........: C:/Ruby4Lich/lich/scripts
    DATA_DIR............: C:/Ruby4Lich/lich/data
    TEMP_DIR............: C:/Ruby4Lich/lich/temp
    LOG_DIR.............: C:/Ruby4Lich/lich/logs
    MAP_DIR.............: C:/Ruby4Lich/lich/maps
    BACKUP_DIR..........: C:/Ruby4Lich/lich/backup
    Ruby location.......: C:\Ruby4Lich\bin\rubyw.exe

    MapDB filename................: map-1589244972.dat
    MapDB last modified...........: 2020-05-11 18:17:15 -0700
    gameobj-data last modified....: 2020-04-02 10:05:22 -0700
    spell-list last modified......: 2019-08-26 11:11:57 -0700

    Running scripts.....: infomon, lnet, uberbar, uberbounty, prettiernum, rnum, uberspells, voodoo, stand, version
    Downstream hooks....: inventory_boxes_off, fix_gameobj_status, lnet-watch-forage, prettynumber, rNums
    Upstream hooks......: inventory_boxes_toggle, infomon, alias-service, lnet, voodoo
    Current threads.....: 22
    ```
    Use `;version SCRIPT [SCRIPT2 [SCRIPT3...]]` to report the installed versions of one or more Lich scripts.
    Use `;version ALL` to report the installed versions of ALL downloaded Lich scripts.
    --- Lich: version has exited.

  8. #8

    Default

    This confirms you are on the 32 bit version. Try moving your LICH directory from Ruby4Lich to your Desktop.


    Do you use a shortcut to start the lich login? Do you just double click on lich.rbw to log in? Do you log in via the website or through SGE?

  9. Default

    I have lich.rbw pinned to my taskbar so effectively I just double click it to start. Log in through SGE via lich. I'll try moving lich to the desktop but can't imagine how that would make a difference...

  10. #10

    Default

    It likely will not. I do not know enough about how Lich works with SGE to be sure there is no problem there. My suggestion after moving the Lich folder would be to reinstall SF from the GS website, and if that does not work, you might have to visit the GS discord scripting channel or help channel and ask for help, since this will be beyond my experience.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •