Results 1 to 10 of 10

Thread: How to trust scripts?

  1. Default How to trust scripts?

    I am unable to use any script that requires ;trust because the version of ruby installed with the autoinstaller does not support that command. Is there a solution to this?

  2. #2

    Default

    I'm having the same issue.

    I'm trying to set up lich with the WFE on Windows 10. When I try to trust any script, I get "--- Lich: this feature isn't available in this version of Ruby "

    Running 2.5.5p157

  3. #3
    Join Date
    Mar 2008
    Location
    N. Carolina, USA
    Posts
    263

    Default

    Using newer versions of LICH and RUBY you no longer need to trust scripts. RUBY trust in v2.0.0 was a false sense of security and was taken out in later versions. What script are you trying to ;trust and what happens when you run it. If you're using a newer version of LICH and new RUBY, you shouldn't need to trust any script anymore.
    Websites
    Tillmen's Lich Homepage
    Lich Wiki Info
    Elanthia Online Forums Archive
    Elanthia Online Github Repository - Collaborative script development by the community. (now home to ;bigshot and gameobj-data.xml)

    Player of Tysong

  4. #4

    Default

    I've been trying to run UberBarWiz to work on the WFE, but I'm getting this:

    Code:
    >;UBW-Theme-SF
    --- Lich: UBW-Theme-SF active.
    --- Lich: UberBarWiz active.
    --- Lich: UberBarWiz has exited.
    
    UberBarWiz is set up as SF mode
    You need to learn to embrace change
    
    NOTE:
    You don't need to launch this every time you launch UberBarWiz.
    This just sets up the files for the first launch.
    
    --- Lich: UberBarWiz active.
    --- Lich: UBW-Theme-SF has exited.
    
    Can't find the files I need
    Download, trust, and run one of the theme packages from the repository
    UBW-theme-sf, -dude or -sexy

  5. #5

    Default

    You're not starting UberBarWiz.lic...you're starting UBW-Theme-Sf.lic
    W3 4R3 4N0NYM0U5.
    W3 4R3 L3610N.
    W3 D0 N07 F0R61V3.
    W3 D0 N07 F0R637.

  6. #6

    Default

    Quote Originally Posted by n0551n3n0m1n3 View Post
    You're not starting UberBarWiz.lic...you're starting UBW-Theme-Sf.lic
    Exact same message when I run UberBarWiz.lic:

    Code:
    ;UberBarWiz
    --- Lich: UberBarWiz active.
    
    Can't find the files I need
    Download, trust, and run one of the theme packages from the repository
    UBW-theme-sf, -dude or -sexy
    
    --- Lich: UberBarWiz has exited.

  7. #7

    Default

    My version info:

    Code:
    Ruby version........: 2.5.5
    Ruby platform.......: i386-mingw32
    Ruby engine.........: ruby
    Lich version........: 4.6.54
    SQLite3 version.....: 1.4.0
    Gtk version.........: 2.24.30
    Cairo version.......: 1.16.0
    ;version Version....: 0.3
    
    LICH_DIR............: Y:/OneDrive/Documents/GemStone IV/lich-4.6.37/lich
    SCRIPT_DIR..........: Y:/OneDrive/Documents/GemStone IV/lich-4.6.37/lich/scripts
    DATA_DIR............: Y:/OneDrive/Documents/GemStone IV/lich-4.6.37/lich/data
    TEMP_DIR............: Y:/OneDrive/Documents/GemStone IV/lich-4.6.37/lich/temp
    LOG_DIR.............: Y:/OneDrive/Documents/GemStone IV/lich-4.6.37/lich/logs
    MAP_DIR.............: Y:/OneDrive/Documents/GemStone IV/lich-4.6.37/lich/maps
    BACKUP_DIR..........: Y:/OneDrive/Documents/GemStone IV/lich-4.6.37/lich/backup
    Ruby location.......: C:\Ruby4Lich\bin\rubyw.exe
    
    MapDB filename................: map-1581801664.dat
    MapDB last modified...........: 2020-02-15 13:54:20 -0800
    gameobj-data last modified....: 2020-02-13 18:58:15 -0800
    spell-list last modified......: 2019-08-18 11:44:49 -0700
    
    Running scripts.....: lnet, autovote, sorter, infomon, version
    Downstream hooks....: lnet-watch-forage, sorter, fix_gameobj_status
    Upstream hooks......: alias-service, lnet, infomon
    Current threads.....: 17

  8. #8

    Default

    Change all names of the scripts to lower case, and use lower case to start.

  9. #9

    Default

    Quote Originally Posted by Risen View Post
    Change all names of the scripts to lower case, and use lower case to start.
    No luck doing this. Same error messages.

  10. #10

    Default

    One thing I would try, is to follow the lichproject.org instructions. It specifically says DO NOT download Ruby 2.1 or higher. This may have been changed since I downloaded it, but I run Ruby 2.0.0-p648 and rarely have issues(except when I fuck something up).
    W3 4R3 4N0NYM0U5.
    W3 4R3 L3610N.
    W3 D0 N07 F0R61V3.
    W3 D0 N07 F0R637.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •