Results 1 to 6 of 6

Thread: Lich Installation Problem

  1. #1

    Default Lich Installation Problem

    Hello guys, brand new to Lich and am trying to give it a shot. So I've installed Ruby 2.0, followed the instructions for downloading and installing Lich. When I run Lich like it describes, I get a prompt which says

    "Lich needs sqlite3 to save settings and data, but it is not installed."

    "Would you like to install sqlite3 now?"

    When I click yes, it does nothing at all. If I try to reopen Lich, it just does the same thing.

  2. #2

    Default

    I am getting the exact same issue on the new computer I built trying to install lich.

  3. #3

    Default

    What you want to do is open up a command line, browse to your RubyXX/bin directory, and execute “gem install sqlite3 -V” followed by “gem install gtk2 -V”, post back any error messages (if any) here and go from there.

    If you're on a Windows 10 machine you can also try the Windows 10 Lich Installer. You may have to uninstall your previous installation of Ruby to use the installer, though.
    Last edited by Eodus; 03-24-2019 at 07:53 PM.

  4. #4

    Default

    I ended up deleting everything and using the link in the wiki, it works perfect now

  5. #5

    Default

    Quote Originally Posted by kutter View Post
    I ended up deleting everything and using the link in the wiki, it works perfect now
    Glad to hear.

  6. Default

    disregard
    Last edited by Clauddvon; 04-21-2019 at 08:52 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •