Results 1 to 4 of 4

Thread: Ok tried a fresh install...of everything. Gems certs are I think out of date???

  1. #1

    Default Ok tried a fresh install...of everything. Gems certs are I think out of date???

    Hey everyone,

    Tried a fresh install of Ruby 2.00 and I get stuck in a loop for sqlite3 install and stuff. CMD screen runs too fast so I looked on the wiki for the cmd code to download all three manually and when I run that...I get the following:

    ERROR: Could not find a valid gem 'sqlite3' (= 1.3.13), here is why:
    Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (https://rubygems.org/specs.4.8.gz)
    ERROR: Could not find a valid gem 'cairo' (= 1.16.1), here is why:
    Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (https://rubygems.org/specs.4.8.gz)
    ERROR: Could not find a valid gem 'gtk2' (= 3.2.9), here is why:
    Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (https://rubygems.org/specs.4.8.gz)

    I didn't have that the first time I installed this but I have a feeling that I didn't do a clean install...after poking around, I still had old directories. Clean install fixed Stormfront (didn't realize that was the scrolling issue problem)...lich was slow as molasses and since no one gave any idears….figured I would do a clean install of everything. Does the certs for ruby.org need to be fixed or something? or do I need to do something. I am afraid to try the other version of Ruby for 64 bit since last time my windows 10 went into a loop of BSOD...so just asking if there is anything I can do with this.

    -Akanah (missing her lich).

  2. #2

    Default

    ok!!! you will need to go here to fix your problem if you have this:

    https://bundler.io/v1.16/guides/ruby...dating-bundler

    Looks like I was missing a cert...guessing that is why others are having issues. Some .pem file. I can download them now!! *fingers crossed*

  3. #3

    Default

    i was going to say. Missing a local root cert OR a version if something in the ruby 2.0 toolchain is so old it doesn't support more modern SSL encryption schemes and rubygems disabled the old stuff (some of the oldest TLS things were officially end of life deprecated in a bunch of places last year).
    Last edited by Donquix; 02-16-2019 at 01:39 PM.
    Mithrilschlong, 2015-03-10 to slightly later on 2015-03-10. You will not be forgotten!

  4. #4

    Default

    It was the root cert....I got that from the link and I am good. YAY! I got my lich back! Ruby 2.0.0 will work for those who have issues with the newer one like me on windows 10 (latest version)...might have to get that root cert on your computer from that link I provided...go it from the ruby website...my scrolling issue is fixed after I re-installed storm front (not sure why the first one didn't followed the video!! but I guess bad installs can happen)....now back to gemstoning...and with my scripts!! Yeah I was afraid it might have been the TLS but it was working before my BSOD loop took out my install of windows so I was hoping it wasn't that...damn reset of the OS I had to do . Anyways...all fixed now.

    Anyone object with me updating the wiki with this information? For any new peeps like me who are still learning the whole lich thing and trying to install fresh...and can't do the newer version yet . Hoping the new computer will solve the issue with me not being able to install the newer Ruby...it is kind of annoying not using the latest and greatest version.

    - Akanah

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •