Results 1 to 5 of 5

Thread: linux 16.04 installation

  1. #1

    Default linux 16.04 installation

    Is there any chance of updating the installation instructions for Ubuntu 16.04? I found some old threads about this from 2016 - I know not many people use linux, but I think it would helpful for at least some of us if the instructions could be updated (because Mint 18 is based on Ubuntu 16.04 too I think this is probably the most widely used distro right now)

    Thanks,
    gromuk
    Last edited by gromuk; 09-29-2017 at 04:55 PM.

  2. #2

    Default

    The Ubuntu 14.10 instructions on lichproject.org worked for me, more or less, but... it wasn't trivial.

    For whatever reason something failed on the 'sudo gem install sqlite3 gtk2 --no-ri --no-rdoc' step. I continued on anyway, and the command line eventually told me to run 'sudo gem install gtk2' which succeeded that time (?) and then Lich started running.

    But since I have ruby 2.3, there were problems there:

    >;go2 town
    --- Lich: go2 active.
    --- Lich: error: $SAFE=2 to 4 are obsolete
    lich.rbw:2533:in `block (3 levels) in <class:Script>'
    lich.rbw:2533:in `block (2 levels) in <class:Script>'
    --- Lich: go2 has exited.

    That can be fixed by monkey patching your lich.rbw, but I'd not recommend that unless you know what you're doing. Seems Tillmen will need to do something to support ruby2.3 or higher eventually (set $SAFE to 1 instead of 3 iff ruby version is 2.3 or higher?). There's probably a way (PPA probably) to get specifically ruby 2.0 in ubuntu 16.04 but I wouldn't know how (beyond googling...).

    tl;dr it can work in ubuntu 16.04 but it's not trivial because ruby 2.3 needs some love

  3. Default

    Quote Originally Posted by Overlordz View Post
    The Ubuntu 14.10 instructions on lichproject.org worked for me, more or less, but... it wasn't trivial.

    For whatever reason something failed on the 'sudo gem install sqlite3 gtk2 --no-ri --no-rdoc' step. I continued on anyway, and the command line eventually told me to run 'sudo gem install gtk2' which succeeded that time (?) and then Lich started running.

    But since I have ruby 2.3, there were problems there:

    >;go2 town
    --- Lich: go2 active.
    --- Lich: error: $SAFE=2 to 4 are obsolete
    lich.rbw:2533:in `block (3 levels) in <class:Script>'
    lich.rbw:2533:in `block (2 levels) in <class:Script>'
    --- Lich: go2 has exited.

    That can be fixed by monkey patching your lich.rbw, but I'd not recommend that unless you know what you're doing. Seems Tillmen will need to do something to support ruby2.3 or higher eventually (set $SAFE to 1 instead of 3 iff ruby version is 2.3 or higher?). There's probably a way (PPA probably) to get specifically ruby 2.0 in ubuntu 16.04 but I wouldn't know how (beyond googling...).

    tl;dr it can work in ubuntu 16.04 but it's not trivial because ruby 2.3 needs some love
    "sudo gem install gtk2" doesn't work for me on the second attempt:

    james@james-XPS-13-9350:~$ sudo gem install gtk2
    [sudo] password for james:
    Building native extensions. This could take a while...
    ERROR: Error installing gtk2:
    ERROR: Failed to build gem native extension.

    current directory: /var/lib/gems/2.3.0/gems/atk-3.1.9/dependency-check
    /usr/bin/ruby2.3 -rubygems /usr/share/rubygems-integration/all/gems/rake-10.5.0/bin/rake RUBYARCHDIR=/var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/atk-3.1.9 RUBYLIBDIR=/var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/atk-3.1.9
    /usr/bin/ruby2.3: No such file or directory -- /usr/share/rubygems-integration/all/gems/rake-10.5.0/bin/rake (LoadError)

    rake failed, exit code 1

    Gem files will remain installed in /var/lib/gems/2.3.0/gems/atk-3.1.9 for inspection.
    Results logged to /var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/atk-3.1.9/gem_make.out
    james@james-XPS-13-9350:~$

  4. Default

    I'm thinking of downgrading my operating system from Ubuntu 16.04 LTS to 14.x, so I can play Gemstone on this Linux laptop.

    Is there a better solution? Thanks! -LizardClan1

  5. Default

    My laptop is newer than Ubuntu 14.04.5 LTS, so I can't find the necessary kernel.

    Oh, well...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •