Results 1 to 9 of 9

Thread: OSX 10.12 + Avalon issue?

  1. #1

    Default OSX 10.12 + Avalon issue?

    Hi all! I'm usually a windows user, but want to get lich running on my macbook for portability.

    After following the instructions here: https://gswiki.play.net/Mac_Installa...ich_(software)

    I'm able to run lich + avalon, HOWEVER: my ruby/lich process is running as a separate task in my OSX dock. It only seems to "progress" when I have it selected, and hangs if I focus Avalon, or the terminal, etc. Has anyone encountered this type of issue before? Is there a system setting or another parameter I need to pass when running lich to make it run 'in the terminal'?

    Thanks!
    interested in high-end CM enhancivces, PM me!

    check out my FWI shop for bounty gems, skins and enhancives!

  2. #2

    Default

    To clarify, it seems to be more of a Mac + Lich + Ruby issue than Avalon. If I'm not running Lich, I can use Avalon just fine.

    It almost seems as though the Lich main loop only proceeds when I click on the ruby icon in the dock
    interested in high-end CM enhancivces, PM me!

    check out my FWI shop for bounty gems, skins and enhancives!

  3. #3

    Default

    Any mac experts out there run into an issue like this before?
    interested in high-end CM enhancivces, PM me!

    check out my FWI shop for bounty gems, skins and enhancives!

  4. #4

    Default

    Sorry I haven't come across that at all and I run Lich on mac half the time.


    Sent from my iPhone using Tapatalk

  5. #5

    Default

    Do this:

    gem list -v 3.0.8 | xargs gem uninstall -aIx
    gem install gtk2

    Then try the game.

  6. #6

    Default

    That didn't work unfortunately

    Half of the gems listed were "default" gems and couldn't be uninstalled-- json, etc. I went through the list and manually uninstalled all the ones that could be. After that, it still would only "progress" when I clicked on the ruby icon in the dock
    interested in high-end CM enhancivces, PM me!

    check out my FWI shop for bounty gems, skins and enhancives!

  7. #7

    Default

    And you need to click it each time for a new line to appear. I've seen this behavior myself personally. I don't know the complete ins and outs of why - but to correct it, I had to take out Homebrew, the gems and start over again with a current xQuartz.

    The key seemed to be ensuring the right version of GTK+ in Homebrew (that long string in the instructions on the wiki). Do you want to walk that path with my assist?

  8. #8

    Default

    That's exactly the experience I'm seeing! PM sent!
    interested in high-end CM enhancivces, PM me!

    check out my FWI shop for bounty gems, skins and enhancives!

  9. #9

    Default

    Risen solved my problems! It required removing all of the relevant brew casks, uninstalling ruby, installing everything again (some from source!), reinstalling ruby and finally installing gtk2. Whew!
    interested in high-end CM enhancivces, PM me!

    check out my FWI shop for bounty gems, skins and enhancives!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •